Qt, staking and .gz


#1

Hi.

A couple of questions have come up.

  1. How do I enable staking in the Qt Wallet, or is it always enabled? Qt intro text says ”With encryption and staking options” but there is no such selection in settings->options.

  2. What is the best way to transfer Bay from Marketplace Client to Qt? Just send them, or is there way to open an existing (Marketplace Client) wallet?

  3. Are there any known issues with the latest bitbayclient-linux-64bit.gz? I can not get the package to open without an error message even though I have downloaded it several times. Clearly question 3) is affiliated with 1) & 2)…

Running Ubuntu 16.04 LTS.

Thanks again!


#2

@curve welcome to bitbay forums

  1. if you don’t lock your wallet it is staking automatically
    you can verify this with the thunder on the left bottom icons
    hovering over it will tell you that you are indeed staking and the expected time to earn a reward

If you encrypted (password protected) your wallet you will need to UNLOCK it everytime you open it in order to let it stake. Both settings under settings menu (encrypt wallet, unlock wallet)

  1. Transfering between marketplace and QT can indeed be done with a simple sending
    there is no way currently to import/export wallets between the 2 (client/QT) however its in the TODO list

  2. I am working with a QT wallet on ubuntu 16 actually and just tried it again and should be working fine.

Make sure that the bitbay-wallet-qt is executable i.e. chmod +x bitbay-wallet-qt and it is better if you run it from the command line ./bitbay-wallet-qt so you can see any error message that comes up.
Running it with right click and pressing execute does not give an error message.

Most probably there is a library missing from your system
Just try it out and paste here any error message you get.