Help with Client Wallet - Linux

resolved

#1

Hello, I’m using the Client Wallet v1.29 and my Operating System is Linux Mint 18.2.

The problem I am having is that lately I can’t use the wallet because it just closes the interface. I run the wallet through the terminal using ‘./BitBay.sh’, it opens the wallet smoothly but then I have an error and it closes the interface but the wallet keeps running in the background and the only solution I have is to kill the process BitMHalo to stop it. I’ll just post here the lines I have before it closes.

Connection attempt: 218
exceeded max connection attemps to Halo, exiting.
QPixmap: It is not safe to use pixmaps outside the GUI thread
(...^^this line more than ten times...)
QPixmap: It is not safe to use pixmaps outside the GUI thread
[xcb] Unknown sequence number while processing queue
[xcb] Most likely this is a multi-threaded client and XInitThreads has not been called
[xcb] Aborting, sorry about that.
Halo: --/../src/xcb_io.c:274: poll_for_event: Assertion '!xcb_xlib_threads_sequence_lost' failed.
./BitBay.sh: line 1: 6795 Aborted                                       ${pwd}./Halo

And after that the interface closes as I said before, but keeps running in the background and the terminal keeps giving lines that I suppose the wallet is still syncing even thought I can’t see it. I’ve already asked help at the Slack but they advised me to post here so I hope you guys can help me. Thanks.


#2

On Linux, Bitbay’s client uses Wine to run. You may have a problem with the Wine Engine. I don’t know well Linux so I’ll ask another team member about it and get back at you later. Meanwhile you can use the Qt Wallet here https://bitbay.market/downloads if you want.


#3

Linux doesn’t use Wine. I’ve never seen this error before. Did the program generate a file called crashlog.dat!? I see it tries to connect and exits!? How long does it take before it crashes!? In the bitbaydata directory is there a debug.log? Send me those files if you have them


#4

Oups sorry on that, I thought it was like the Mac OSX build! :sweat:


#5

It only shows the interface around 10 seconds and then it closes but the terminal keeps running, this started happening when one day I turned off my computer by mistake when I removed the power cable and the wallet was open and it never worked ever since. I’ll check and send those files later when I have the time, thanks for the reply.


#6

As long as you have your private keys you will be fine. Might require having to uninstall then reinstall Client though. But as David said, if you got any crashlog.dat files or debug logs, please post them here just for the sake of our knowing as to why the abrupt shutdown caused the program to fail to run anymore.
They don’t contain any vital private information


#7

Ok I’ve the debug.log file but how do I upload it here? And the other file I can’t find, in what folder is it? If it generates in the bitbaydata folder then I don’t have it.


#8

@dzimbeck I’ve sent you the file through Slack, let me know if you need anything else. Thanks