BitBay marketplace client 1.30 (Linux) won't start


#1

Hi.
Anyone else faced this symptom when updating client?

I downloaded and extracted the 64bit Linux 1.30 client on my computer. As I start Halo and it prompts me to “choose language” I pick english and hit “apply” and then…the window disappears and nothing happens.
Tried re-downloading but it didn’t help. The 1.29 version is starting ok (though a while ago I stopped receiving staking rewards for some unknown reason…).

I’m running ubuntu 16.04 LTS
Intel Core 2 Duo CPU 2.33GHz x2

Thanks in advance!


#2

Hi, thank you for your interest in Bitbay! :slight_smile:
Make sure you aren’t running the 1.29 version at the same time (see in the running processes). If you got any crashlog.dat files or debug logs, please post them here. Also are you sure you downloaded the last version? Because it should 1.31 and not 1.3.


#3

Yep. Verified that the version is 1.31 and that there are no residual processes running.


#4

I’m having the same problem here with Linux Mint 18.2. Any help would be appreciated.


#5

It might be the new GUI. I’ve been hearing similar reports for Linux. Does the console say anything? Is there a file called crashlog.dat?!


#6

@dzimbeck In my case I don’t have any crashlog.dat file but I have this error in the terminal “ImportError: No module named QtWebKit.QWebView”. After that the terminal stops and the wallet closes.


#7
Fontconfig error: "/etc/fonts/conf.d/10-scale-bitmap-fonts.conf", line 72: non-double matrix element

Fontconfig error: “/etc/fonts/conf.d/10-scale-bitmap-fonts.conf”, line 72: non-double matrix element
Fontconfig warning: “/etc/fonts/conf.d/10-scale-bitmap-fonts.conf”, line 80: saw unknown, expected number

Data Directory: ./BitMData/

Loading existing config files from ./BitMData/
2018-03-25 13:14:08,407 - WARNING - Could not get the package version from pkg_resources

BITMHALO PATH: ./
Bitmessage Vesion 0.4.4 is not Supported officially.
2018-03-25 13:14:08,418 - DEBUG - Database file already exists.
2018-03-25 13:14:08,429 - DEBUG - Loaded 0 objects from disk into the objectProcessorQueue.
2018-03-25 13:14:08,429 - DEBUG - reloading keys from keys.dat file
2018-03-25 13:14:08,436 - DEBUG - reloading subscriptions…
Traceback (most recent call last):
File “main__Halo.py”, line 15199, in Gtranslate
File “yandex_translate/init.py”, line 150, in translate
YandexTranslateException: None
2018-03-25 13:14:11,346 - ERROR - Fatal message received from Peer(host=‘185.19.31.46’, port=8080): Server full, please try again later…
2018-03-25 13:14:11,558 - ERROR - Fatal message received from Peer(host=‘85.25.152.9’, port=8444): Server full, please try again later…
2018-03-25 13:14:14,900 - INFO - inv message lists 45904 objects. Of those 45904 are new to me. It took 0.0672118663788 seconds to figure that out.
2018-03-25 13:14:15,104 - DEBUG - advertising inv with hash: b32f09b3374894f7ac11a1e99742b6c03efdaa13ac4588b7d868691d405a4748
2018-03-25 13:14:15,110 - INFO - This was NOT an acknowledgement bound for me.
2018-03-25 13:14:15,112 - INFO - Length of time program spent failing to decrypt this message: 0.00193214416504 seconds.
2018-03-25 13:14:15,780 - INFO - inv message lists 44407 objects. Of those 44406 are new to me. It took 0.0370559692383 seconds to figure that out.
2018-03-25 13:14:15,981 - DEBUG - advertising inv with hash: 87ef956cdc9719ca8bf6b9244f87f08cb5b48b8cd86d8f322f396f6210b14e67
2018-03-25 13:14:15,987 - DEBUG - the tag requested in this getpubkey request is: c5a40f3411817a9ba03df27d7839dd98b854d4fea089f6ffa9c251456e1f61e5
2018-03-25 13:14:15,987 - INFO - This getpubkey request is not for any of my keys.
2018-03-25 13:14:16,603 - DEBUG - advertising inv with hash: 04b0925721e57e787a13fb29f9081511e4cabd086ec020cd59d9ffd86b865b10
2018-03-25 13:14:16,609 - DEBUG - the tag requested in this getpubkey request is: c5a40f3411817a9ba03df27d7839dd98b854d4fea089f6ffa9c251456e1f61e5
2018-03-25 13:14:16,610 - INFO - This getpubkey request is not for any of my keys.
2018-03-25 13:14:17,000 - DEBUG - advertising inv with hash: e1da4309fbf5f684430ed68a6fc792100c4bd2f303cfbb0ea77d5b8ce8604ad0
2018-03-25 13:14:17,009 - INFO - This was NOT an acknowledgement bound for me.
2018-03-25 13:14:17,010 - INFO - Length of time program spent failing to decrypt this message: 0.00112104415894 seconds.
2018-03-25 13:14:17,887 - DEBUG - advertising inv with hash: 8fa36b46814e125a5d646cedaebec4c1f0acf904890b5fe5b9424bf6d1182f54
2018-03-25 13:14:17,900 - DEBUG - the tag requested in this getpubkey request is: c5a40f3411817a9ba03df27d7839dd98b854d4fea089f6ffa9c251456e1f61e5
2018-03-25 13:14:17,902 - INFO - This getpubkey request is not for any of my keys.
2018-03-25 13:14:18,285 - DEBUG - advertising inv with hash: cebbe74b30880202425bb7f179a35d1e2dfd16046587ad835f2c98cbc6af7ae7
2018-03-25 13:14:18,290 - INFO - This was NOT an acknowledgement bound for me.
2018-03-25 13:14:18,291 - INFO - Length of time program spent failing to decrypt this message: 0.000823974609375 seconds.
Traceback (most recent call last):
File “”, line 6, in
File “main.py”, line 128, in
File “main__Halo.py”, line 29391, in
File “main__Halo.py”, line 23453, in init
File “gui/mainwindow.py”, line 804, in setupUi
uic.loadUi(self.ApplicationPath+"/gui"+’/forms/ChatPanel.ui’, self.Chat)
File “PyQt4/uic/init.py”, line 223, in loadUi
File “PyQt4/uic/Loader/loader.py”, line 71, in loadUi
File “PyQt4/uic/uiparser.py”, line 929, in parse
File “PyQt4/uic/uiparser.py”, line 770, in createUserInterface
File “PyQt4/uic/uiparser.py”, line 748, in traverseWidgetTree
File “PyQt4/uic/uiparser.py”, line 459, in createLayout
File “PyQt4/uic/uiparser.py”, line 748, in traverseWidgetTree
File “PyQt4/uic/uiparser.py”, line 502, in handleItem
File “PyQt4/uic/uiparser.py”, line 748, in traverseWidgetTree
File “PyQt4/uic/uiparser.py”, line 224, in createWidget
File “PyQt4/uic/uiparser.py”, line 748, in traverseWidgetTree
File “PyQt4/uic/uiparser.py”, line 459, in createLayout
File “PyQt4/uic/uiparser.py”, line 748, in traverseWidgetTree
File “PyQt4/uic/uiparser.py”, line 502, in handleItem
File “PyQt4/uic/uiparser.py”, line 748, in traverseWidgetTree
File “PyQt4/uic/uiparser.py”, line 215, in createWidget
File “PyQt4/uic/uiparser.py”, line 176, in setupObject
File “PyQt4/uic/objcreator.py”, line 106, in createQObject
File “PyQt4/uic/objcreator.py”, line 131, in findQObjectType
File “PyQt4/uic/Loader/qobjectcreator.py”, line 107, in search
ImportError: No module named QtWebKit.QWebView


#8

I am still having this problem, any solution?


#9

Yes I have fixed this. The Linux version had an issue with a missing QT library that won’t load some objects from UI files. Since one of our devs had submitted the new UI in the last update. So yes the working Linux will be uploaded very soon within a week or so.


#10

So has the wallet been updated already or is it still being fixed?


#11

It has been fixed & updated! :slight_smile: